Get in touch
Back
Resolved

Infrastructural issue

Started .

Production Tacton CPQ NA Early Access Tacton CPQ NA
Created

Earlier today, an infrastructural issue caused a temporary disruption of the Tacton CPQ service in the North American region. The issue has been resolved, and service is now fully restored. We continue to monitor system performance to ensure stability and prevent recurrence.

Posted .